Volkswagen Rcd330 Plus Head Unit Guide , Firmware Update
RCD330 187E - Microphone is dead - Printable Version

+- Volkswagen Rcd330 Plus Head Unit Guide , Firmware Update (http://rcd330plus.com)
+-- Forum: Rcd 330 PLus Guide And Firmware Public (http://rcd330plus.com/forumdisplay.php?fid=1)
+--- Forum: Rcd330 PLus Experience (http://rcd330plus.com/forumdisplay.php?fid=18)
+--- Thread: RCD330 187E - Microphone is dead (/showthread.php?tid=1317)

Pages: 1 2


RCD330 187E - Microphone is dead - amar98 - 04-29-2019

I bought RCD330 187E Noname version. Everything worked so great and smooth. Bluetooth connectivity, Phone Calls, Voice Command, Android Auto and everything else worked flawlessly.

After few day's use, its microphone stopped working. When my phone is connected to Bluetooth, person at the other end is not able to hear me. Also, when i press voice command button, voice command gets activated but it is not receiving any audio inputs. All these symptoms indicate that my phone's microphone is dead.

Steps tried without any luck -
1- Removed phone paring and repaired
2- Tried a different phone
3- Head-unit reset by pressing power button
4- Tried installing a different firmware (mine came with S/w: 5515 and I flashed S/w: 5314)

I need some expert advise to fix this issue!


RE: RCD330 187E - Microphone is dead - amar98 - 04-30-2019

Is there any way to fix this issue?
Does it require motherboard repair?

Forum experts please reply.


RE: RCD330 187E - Microphone is dead - Cheesethief - 04-30-2019

(04-30-2019, 05:09 PM)amar98 Wrote: You are not allowed to view links.

[To see links please register here]

or

[To see links please register here]

to view.
Is there any way to fix this issue?
Does it require motherboard repair?

Forum experts please reply.

Do you have VCDS/VAG-COM or OBDEleven? You could activate Engineering Test mode and see if the microphone is picking up anything. 

How to activate Engineering Test Mode: You are not allowed to view links.

[To see links please register here]

or

[To see links please register here]

to view.

Honestly though, this does sound like the microphone went bad unfortunately. That would probably require soldering a new microphone in.


RE: RCD330 187E - Microphone is dead - ddren - 05-01-2019

(04-29-2019, 09:53 AM)amar98 Wrote: You are not allowed to view links.

[To see links please register here]

or

[To see links please register here]

to view.
I bought RCD330 187E Noname version. Everything worked so great and smooth. Bluetooth connectivity, Phone Calls, Voice Command, Android Auto and everything else worked flawlessly.

After few day's use, its microphone stopped working. When my phone is connected to Bluetooth, person at the other end is not able to hear me. Also, when i press voice command button, voice command gets activated but it is not receiving any audio inputs. All these symptoms indicate that my phone's microphone is dead.

Steps tried without any luck -
1- Removed phone paring and repaired
2- Tried a different phone
3- Head-unit reset by pressing power button
4- Tried installing a different firmware (mine came with S/w: 5515 and I flashed S/w: 5314)

I need some expert advise to fix this issue!

First, according to Cheesethief, to detect the failure of the microphone hardware.(Very small chance of damage).



[attachment=572]

[attachment=571]

[attachment=570]

[attachment=569]

Second way, 
If the microphone is bad, you need to buy an external microphone to connect the rear plug.
This microphone is mounted next to the interior light above the head.

[attachment=573]


RE: RCD330 187E - Microphone is dead - amar.soul - 05-09-2019

Thanks for the reply! I was waiting for my new OBDEleven device to arrive! Finally I got it and gave it a try today.  Here are some of the screenshots.

[attachment=601]
[attachment=602]
[attachment=603]
[attachment=604]

I enabled Development mode using OBDEleven and then kept pressing the Setup button. but I do not see the additional troubleshooting options. Am I missing anything?

Edit: I am not even sure if that's how development mode is enabled in OBDEleven. any help on this is appreciated!

thanks for posting that video link! Smile


RE: RCD330 187E - Microphone is dead - ddren - 05-09-2019

Hi.
You need to activate Engineering Test Mode
You are not allowed to view links.

[To see links please register here]

or

[To see links please register here]

to view.

Otherwise long press setup botton is invalid.


RE: RCD330 187E - Microphone is dead - amar.soul - 05-09-2019

I was finally able to enable 'Development Test Mode' using OBDEleven (I'll post the steps later)

Findings - When I tap on the microphone (which is just below the Media button), it picks up the sound and microphone voltage changes. Seems like microphone hardware is still alive!  Smile




Here are some more screenshots (of audio settings and device version)

[attachment=611]

[attachment=610]

since hardware seems to be working fine, what do you think is the issue? does it require firmware update?


RE: RCD330 187E - Microphone is dead - Cheesethief - 05-09-2019

(05-09-2019, 08:43 PM)amar.soul Wrote: You are not allowed to view links.

[To see links please register here]

or

[To see links please register here]

to view.
I was finally able to enable 'Development Test Mode' using OBDEleven (I'll post the steps later)

Findings - When I tap on the microphone (which is just below the Media button), it picks up the sound and microphone voltage changes. Seems like microphone hardware is still alive!  Smile




Here are some more screenshots (of audio settings and device version)





since hardware seems to be working fine, what do you think is the issue? does it require firmware update?

Definitely check if reflashing firmware might help resetting things. Depending on which firmware you have, either update it to something newer or flash an older firmware and then flash it back to the new firmware. Flashing the same firmware as you have on it will end you up with a "variant conflict" error, so it has to be a different version number than your current firmware.


RE: RCD330 187E - Microphone is dead - amar.soul - 05-10-2019

Hi, what I noticed is that when i speak really loud near the microphone it picks up the sound. I tried Good Assistant voice command and did work when speaking very loud near the microphone. 

I couldn't see any improvement in microphone behavior after installing an older firmware and also when i restored the current firmware!

What could be the issue? software? or hardware? I need someone's expert opinion here! please help!!


RE: RCD330 187E - Microphone is dead - Cheesethief - 05-11-2019

(05-10-2019, 11:57 AM)amar.soul Wrote: You are not allowed to view links.

[To see links please register here]

or

[To see links please register here]

to view.
Hi, what I noticed is that when i speak really loud near the microphone it picks up the sound. I tried Good Assistant voice command and did work when speaking very loud near the microphone. 

I couldn't see any improvement in microphone behavior after installing an older firmware and also when i restored the current firmware!

What could be the issue? software? or hardware? I need someone's expert opinion here! please help!!

Hardware most likely. Sounds like your microphone is working, but poorly.